Opened 14 years ago

Closed 12 years ago

#481 closed defect (wontfix)

debugAtAllCosts & IE & run from file system gives exceptions on page load

Reported by: Morris Johns Owned by: anonymous
Priority: lowest Milestone: 0.9
Component: General Version: 0.3
Keywords: debugAtAllCosts __package__ Runtime error Cc:
Blocked By: Blocking:

Description

The cause: when using debugAtAllCosts, if the same .* dependency is given to dojo.require() twice, then there is a request made for the nonexistant file: dojo/src/package.js This usually happens indirectly, e.g. if you have: dojo.require("dojo.event.*"); dojo.require("dojo.widget.Manager"); then you get the problem because dojo.widget.Manager also requires dojo.event.*

It also happens when you are using your own package directory: dojo.hostenv.setModulePrefix('ourWidgets', '../ourWidgets'); dojo.widget.manager.registerWidgetPackage('ourWidgets'); because this causes a request for: ourWidgets/package.js

If the above behaviour of scanning for packages is correct, then ignore this issue. However I am not sure it is from notes in the FAQ, and because src/package.js was removed at some point (became dojo.js?).

The IE problem (which there appears to be no way of fixing) is that IE gives an exception if a <script src="Foo"> tag references a non-existant file from a page running on the local file system. The exception: A Runtime error has occured, Line 1, Error Invalid Character. dojo.hostenv.writeIncludes() includes non-existant file refs to src/package.js or ourWidgets/package.js

Change History (2)

comment:1 Changed 13 years ago by dylan

Milestone: 0.5

comment:2 Changed 12 years ago by Adam Peller

Resolution: wontfix
Status: newclosed

no longer applies to 0.9

Note: See TracTickets for help on using tickets.