Opened 14 years ago

Closed 14 years ago

Last modified 12 years ago

#48 closed defect (fixed)

load event called before widgets are completely initialized - IE only

Reported by: sjmiles@… Owned by: alex
Priority: blocker Milestone:
Component: Widgets Version:
Keywords: Cc:
Blocked By: Blocking:

Description

I tested my load event ("init") this way:

dojo.hostenv.modulesLoadedListeners.push(init)

and this way

dojo.event.connect(dojo.hostenv, "loaded", dj_global, "init")

In both cases, my widgets were not yet registered in the widget manager when 'init' was invoked. In the second case an 'unknown' widget was registered while in the first, no widgets were registered at all (at "init" time).

The problem occurs in IE6 but not in FF 1.0.6.

Change History (6)

comment:1 Changed 14 years ago by anonymous

Priority: normalhigh
severity: normalcritical

comment:2 Changed 14 years ago by sjmiles@…

I increased the severity level on this problem because it's nigh impossible to prevent widget based applications to fail on IE unless the init( ) delay is extremely high (say, 10 seconds) which obviously nerfs all the hard work you guys did on keeping performance high.

comment:3 Changed 14 years ago by anonymous

Priority: highhighest
severity: criticalblocker

comment:4 Changed 14 years ago by alex

Milestone: 0.1release
Owner: changed from Alex to alex
Status: newassigned

see [1089] for a possible fix. Still need verification from sjmiles that the issue is indeed fixed before I can close this.

comment:5 Changed 14 years ago by alex

Resolution: fixed
Status: assignedclosed

this appears to be fixed.

comment:6 Changed 12 years ago by (none)

Milestone: 0.1release

Milestone 0.1release deleted

Note: See TracTickets for help on using tickets.