Opened 12 years ago

Closed 11 years ago

#4790 closed defect (fixed)

color palette: mouseover state is not cleared when click on color in IE 7

Reported by: Becky Gibson Owned by: bill
Priority: high Milestone: 1.2
Component: Dijit Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by haysmark)

The problem only occurs in IE7 when the color palette is opened via a button or menu.

If you open the color palette from a menu or dropdown button (test_menu.html and test_button.html) the white border that is drawn when you mouseover a color is not cleared when you click that color.

in test_button.html: 1) click on the color button and color palette is displayed

2) click on a color in the color palette. The color palette is closed and focus goes back to button.

3) click on button again to open the color palette. The mouseover border is visible on the color that was clicked in step 2.

Change History (6)

comment:1 Changed 12 years ago by Becky Gibson

We can probably live with this for 1.0 but assigned to bill to let him decide.

comment:2 Changed 12 years ago by bill

Milestone: 1.01.1

comment:3 Changed 11 years ago by bill

Milestone: 1.11.2

comment:4 Changed 11 years ago by haysmark

Description: modified (diff)
Owner: changed from bill to haysmark

comment:5 Changed 11 years ago by haysmark

Owner: changed from haysmark to bill

This seems to be fixed now? I can't reproduce it on any of my machines anyway.

comment:6 Changed 11 years ago by Becky Gibson

Resolution: fixed
Status: newclosed

I agree this has been indirectly fixed so am closing.

Note: See TracTickets for help on using tickets.