Opened 12 years ago

Closed 11 years ago

#4781 closed defect (fixed)

slider: when move slider via mouse it is not shown as focused

Reported by: Becky Gibson Owned by: Becky Gibson
Priority: low Milestone: 1.2
Component: Accessibility Version: 0.9
Keywords: Cc: dante
Blocked By: Blocking:

Description

When I set focus to the slider via the keyboard the bar darkens to indicate focus (thanks dante). But, if I then use the mouse to move the slider the focus indication is lost. But, focus is still on the slider because I can go back to using the arrow keys to move the slider. This may be by design - perhaps we don't want the mouse user to "see" the darker slider bar?

Change History (5)

comment:1 Changed 12 years ago by bill

Hmm, that's not by design... ok somehow the blur handler is firing but we aren't getting another focus event?

PS: what browser?

comment:2 Changed 12 years ago by Karl Tiedt

(In [10952]) fixes #4775 fixes #4754 refs #4781 updated test file for the first ticket... and added dijit.focus() call to onBarClick function for 2nd ticket... third ticket I believe might be a bug in dijit.focus() test it out by loading test_Slider.html and then doing dijit.byId('slider1').focus() it flashes focused and then unfocused.

comment:3 Changed 12 years ago by bill

(In [10960]) Fix tabbing. refs #4775, #4754, #4781.

comment:4 Changed 12 years ago by Becky Gibson

Milestone: 1.11.2

comment:5 Changed 11 years ago by Becky Gibson

Resolution: fixed
Status: newclosed

I no longer see the problem with focus described with [10952] in FF's on Mac and Win and IE's. Not sure if the change for #5020 affected this or not (I suspect not). Closing as fixed.

Note: See TracTickets for help on using tickets.