Opened 12 years ago

Closed 12 years ago

#4748 closed defect (fixed)

No focus indication on ComboButton in toolbar

Reported by: simonjb Owned by: Becky Gibson
Priority: high Milestone: 1.1
Component: Accessibility Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

On FF focus is indicated on the titleNode but not on the popupStateNode. On IE6 and IE7 focus is not indicated on either node. To reproduce, open dijit/tests/test_Toolbar.html.

Attachments (2)

4748.patch (1.9 KB) - added by Becky Gibson 12 years ago.
changes to button.js and tundra/button.css
4748a.patch (3.1 KB) - added by Becky Gibson 12 years ago.
updated change to target only toolbar buttons in IE and FF2

Download all attachments as: .zip

Change History (9)

comment:1 Changed 12 years ago by Becky Gibson

Milestone: 1.0

comment:2 Changed 12 years ago by Adam Peller

Milestone: 1.01.1

might be fixed in FF3, needs attention on ie

comment:3 Changed 12 years ago by Becky Gibson

Save button on first toolbar is a combobutton. Focus works for combobutton on 03/03 daily minefield (FF3) build. On FF2 focus is shown the first time the button gets focus but then never after that.

Changed 12 years ago by Becky Gibson

Attachment: 4748.patch added

changes to button.js and tundra/button.css

comment:4 Changed 12 years ago by Becky Gibson

attached patch fixes things but requires an onfocus and onblur handler for combobutton nodes and to manually add/remove a class. I can't use the _setStateClass mechanism because that is at the widget level and this needs to deal with focus within the widget. This fix also allows focus to show on the standalone combobutton in FF2. However, it makes focus on the standalone button on IE6 look much worse. The focus on the toolbar combobutton in IE 6 doesn't look very good, but it is better than not showing focus at all. The question is, should I live with the ugly focus on standalone combobutton in IE6, add an if statement to check for IE6 in the code, or is there some other CSS magic I can plan to have this not affect the IE6 stand alone combobutton?

comment:5 Changed 12 years ago by Becky Gibson

Status: newassigned

Changed 12 years ago by Becky Gibson

Attachment: 4748a.patch added

updated change to target only toolbar buttons in IE and FF2

comment:6 Changed 12 years ago by Becky Gibson

updated patch only modifies the style for combobuttons in a toolbar and only on IE and FF2 since focus is properly shown in FF3. It means adding an if clause in the onfocus and onblur handlers so the styles do not get applied in FF3 - I have some concerns with that but applying the styles in FF3 makes the focus on combobuttons in a toolbar look bad.

comment:7 Changed 12 years ago by Becky Gibson

Resolution: fixed
Status: assignedclosed

(In [12906]) fixes #4748 added onfocus and onblur handler for combobutton pieces. Needed to manually add and remove classes since can't use setStateClass since that is at the widget level and combobutton has two parts which are focused separately. Added classes to show focus on combobuttons in toolbar on IEs and FF2 and focus on standalone combobutton in FF2 (where it was an isssue). Added a class for dj_ff2.

Note: See TracTickets for help on using tickets.