Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#4743 closed defect (wontfix)

dijit.form.FilteringSelect doesn't work in IE6 with Japanese characters

Reported by: guest Owned by: Adam Peller
Priority: high Milestone:
Component: Dijit - Form Version: 0.9
Keywords: i18n Cc: hwcdl@…
Blocked By: Blocking:

Description

Web Browser(version) :InternetExplorer(6.0.2800.1106)
Dojo Widget :dijit.form.FilteringSelect
File :dijit/tests/form/test_FilteringSelect.html

I typed Japanese or Chinese characters on FilteringSelect#7,FilteringSelect#8
but,AutoComplete & Filtering doesn't work!!

Attachments (3)

FilteringSelect.png (27.2 KB) - added by guest 12 years ago.
dijit-FilteringSelect-fix-4743.patch (1.2 KB) - added by Adam Peller 12 years ago.
patch from Evan Huang (IBM, CCLA) to fix up doc URL reference for target XML file
IME setting.png (49.6 KB) - added by guest 12 years ago.

Download all attachments as: .zip

Change History (18)

comment:1 Changed 12 years ago by Adam Peller

Cc: hwcdl@… added
Keywords: i18n added
Owner: set to Adam Peller

Changed 12 years ago by guest

Attachment: FilteringSelect.png added

Changed 12 years ago by Adam Peller

patch from Evan Huang (IBM, CCLA) to fix up doc URL reference for target XML file

comment:2 Changed 12 years ago by Adam Peller

The patch fixes two issues:

  1. No dropdown info when copying text into ComboBox?.(FF, IE6/7)
  2. No dropdown info when inputting Chinese characters. (IE6/7)
    • The root reason is both in IE and FF, inputting each Chinese or Japanese character through IME results a key event with charCode=0.
    • In FF there will be a compositionend event as Bill Keese said, but none in IE. So in IE this patch simply does search for each key event(including charCode=0)
    • This may not be the best way as I haven't found a corresponding event like compositionend in IE.

comment:3 Changed 12 years ago by Adam Peller

Resolution: fixed
Status: newclosed

(In [11075]) Better handling of DBCS input. Fixes #4743

comment:4 in reply to:  2 Changed 12 years ago by guest

Resolution: fixed
Status: closedreopened

Replying to peller:

The patch fixes two issues:

  1. No dropdown info when copying text into ComboBox?.(FF, IE6/7)
  2. No dropdown info when inputting Chinese characters. (IE6/7)



It is not Fixed・・・

OS(version):Microsoft Windows2000(5.002195 Service Pack4) *Not WindowsXP...
Web Browser(version) :!InternetExplorer?(6.0.2800.1106)

comment:5 Changed 12 years ago by Adam Peller

are you confirming that it works in XP but not in win2k?

comment:6 in reply to:  5 Changed 12 years ago by guest

Replying to peller:

are you confirming that it works in XP but not in win2k?


It works normally in WindowsXP & IE6,

but doesn't work in Windows2000 & IE6.

comment:7 Changed 12 years ago by Adam Peller

we've been unable to reproduce the problem in win2k/IE6, so there must be some other factor.

comment:8 in reply to:  7 Changed 12 years ago by guest

Replying to peller:

we've been unable to reproduce the problem in win2k/IE6, so there must be some other factor.


I also,tested with PC in which other Windows2000 is installed.
Then,FilteringSelect works normally.....

this other PC is IME2000.
My PC is IME2003.
Then, I began to doubt IME.

As a result,In the combination of Windows2000 and IME2003 and IE6,
the case to use "IME2003 of default setting",
FilteringSelect doesn't work.

Please refer to the attached image.(IME setting.png)

In the setting of IME,When setting it to "Doesn't use Detaild Text service",
FilteringSelect work normally...

but...,Please fix!

Changed 12 years ago by guest

Attachment: IME setting.png added

comment:9 Changed 12 years ago by bill

BTW, what are you expecting from FilteringSelect? for Japanese? It currently works like this:

  1. type hiragana
  2. convert to kanji using IME
  3. see list of possible completions (from FilteringSelect?)

I think it's strange to have two consecutive drop downs, but is that normal for you?

comment:10 in reply to:  9 Changed 12 years ago by guest

Replying to bill:

BTW, what are you expecting from FilteringSelect? for Japanese? It currently works like this:

  1. type hiragana
  2. convert to kanji using IME
  3. see list of possible completions (from FilteringSelect?)

I think it's strange to have two consecutive drop downs, but is that normal for you?

  1. I typed hiragana. (みなみ[minami] or なん[nann])
  2. I pushed spacebar to convert it into the kanji. (南)
  3. I pushed enterkey to fix conversion.
  4. Then,I sow list of possible completions from FilteringSelect.(Please refer to FilteringSelect.png)

"list of possible completions" does't is not filtered.
It is not filtered in the character "南".
I think that it is strange.

I think it is normal if becoming it like this:

Input:"南"
List of possible completions:"南北","南口","南区"...

comment:11 Changed 12 years ago by bill

Priority: highestnormal

comment:12 Changed 12 years ago by Adam Peller

Milestone: 1.01.1

iiuc, the bug is now limited to a single version of an IME, and we have no idea how to fix, so deferring

comment:13 Changed 12 years ago by Adam Peller

Milestone: 1.1

there's no fix in sight, and given the old OS, this may end up as a 'wontfix' without a patch.

comment:14 Changed 12 years ago by Adam Peller

Resolution: wontfix
Status: reopenedclosed

comment:15 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.