Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#4739 closed defect (fixed)

TextBox type=password ignored

Reported by: simonjb Owned by: bill
Priority: high Milestone: 1.0
Component: Dijit - Form Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

To reproduce:

  • open dijit/tests/form/test_validate.html
  • type in the textbox labeled "Password"
  • characters not rendered as "*"
  • Firebug reports the input's type as "text"

Attachments (1)

TextBox.js.diff (692 bytes) - added by guest 12 years ago.

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by guest

Attachment: TextBox.js.diff added

comment:1 Changed 12 years ago by guest

[cla][patch] from Nicola Rizzo nicola.rizzo+dojo (at) gmail.com

comment:2 Changed 12 years ago by bill

Resolution: fixed
Status: newclosed

(In [10911]) Fixes #4739: TextBox? type=password ignored Can't do setAttribute(), changing the type of the field after the fact, because it doesn't work on IE, so need to have type="${type}" in the template.

comment:3 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.