Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4716 closed defect (fixed)

position of TimePicker popup is awkward

Reported by: Adam Peller Owned by: haysmark
Priority: high Milestone: 1.0
Component: Dijit Version: 0.9
Keywords: Cc: dante, owen, Adam Peller, Becky Gibson
Blocked By: Blocking:

Description

the location of the popup, unlike the Calendar popup, obscures the actual textbox and makes it difficult or impossible to type in the field.

Attachments (2)

4716.patch (390 bytes) - added by haysmark 12 years ago.
Fixes #4716. Added dijit.css rule to make TimePicker? quarter-hours smaller.
4716.2.patch (2.4 KB) - added by haysmark 12 years ago.
Fixes #4716. TimePicker? implements Calendar-style spacer and locks the TimePicker? height when it appears.

Download all attachments as: .zip

Change History (17)

comment:1 Changed 12 years ago by haysmark

It's a fluke that occurs with all popups when you don't have a big enough viewable area. Basically the TimePicker? is too big.

It would help to have those quarter-hour selections the right size in the styling but dante rescheduled it for 1.1.

comment:2 Changed 12 years ago by Adam Peller

hmm... I'm thinking it's a problem because the left of the popup is positioned to align with the left side of the input widget.

comment:3 Changed 12 years ago by haysmark

So this is mainly about small viewable areas. Technically Calendar will encounter this problem for much smaller areas. Where do you think they should go? To the b/t-right instead of the left?

comment:4 Changed 12 years ago by Adam Peller

not sure. maybe to the right of the widget, by default? yeah, if you're crunched for space, I'm sure there will be overlap, but the default should probably look nice.

comment:5 Changed 12 years ago by Adam Peller

ah, got it. So perhaps the problem is that the time picker is so tall. Can we use a smaller default? I guess, unlike the Calendar, it really has more of a vertical orientation. Perhaps having a popup fallback to positioning itself off to the side would be nice, but that might be really difficult.

comment:6 Changed 12 years ago by haysmark

Yes the vertical size should really be much smaller, which we can accomplish by correctly styling the quarter-hours. I thought that because this is a styling issue I should let dante change that since he has that ticket. On the other hand, dante rescheduled that for 1.1 so we should look for a solution now.

What if I introduced a dojo.css rule to make the quarter-hours smaller by default across all themes? Does that sound good to you?

comment:7 Changed 12 years ago by haysmark

I mean dijit.css.

comment:8 Changed 12 years ago by Adam Peller

Cc: dante owen Adam Peller Becky Gibson added

you read my mind :-) I agree this much is a must have for 1.0. Didn't we have styling on this before? Where did it go?

If you could attach such a patch, let's have dante review it, since he's the CSS king.

comment:9 Changed 12 years ago by haysmark

See #4133.

comment:10 Changed 12 years ago by haysmark

Oh wait I left out a change.

Changed 12 years ago by haysmark

Attachment: 4716.patch added

Fixes #4716. Added dijit.css rule to make TimePicker? quarter-hours smaller.

comment:11 Changed 12 years ago by haysmark

So with this patch you notice an existing bug in TimePicker? where the bottom button moves around as you scroll down. You couldn't see it before because all of the heights were the same. I have a fix ready that I tried to add into this patch but the fix is really pending #4714.

comment:12 Changed 12 years ago by Adam Peller

(In [10839]) make :15 minute marks smaller (but still big enough to click on) and added borders so we can see them. Refs #4716

Changed 12 years ago by haysmark

Attachment: 4716.2.patch added

Fixes #4716. TimePicker? implements Calendar-style spacer and locks the TimePicker? height when it appears.

comment:13 Changed 12 years ago by haysmark

Here is a patch to basically keep the down arrow in place as you scroll. This patch fixes the regression created by the small quarter hours.

comment:14 Changed 12 years ago by bill

Resolution: fixed
Status: newclosed

I can't see how 4716.2.patch could work; position:absolute children do not affect the size of the parent. But anyway, we've fixed the original issue (caused by TimePicker? being too tall) so I'm closing this bug.

comment:15 Changed 12 years ago by Adam Peller

I think we had a couple different defects rolled up in this ticket. Mark, we can pursue the other stuff in 1.1 in a separate ticket if you think it's still necessary.

Note: See TracTickets for help on using tickets.