Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#4714 closed defect (fixed)

TimePicker: highlight selected option

Reported by: haysmark Owned by: haysmark
Priority: high Milestone: 1.0
Component: Dijit - Form Version: 0.9
Keywords: Cc: Adam Peller
Blocked By: Blocking:

Description

Transplanted from the long and old #599 per Adam:

When you click in a TimeTextBox? to open the TimePicker?, the value inside the textbox should be highlighted in the picker itself.

Attachments (2)

4714.patch (2.3 KB) - added by haysmark 12 years ago.
Fixes #4714. TimePicker? highlights the currently selected option. The currently selected option appears adjacent to the TextBox? instead of in the middle.
4714.2.patch (1022 bytes) - added by haysmark 12 years ago.
Fixes #4714. TimePicker? highlights the currently selected option.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 12 years ago by haysmark

Owner: set to haysmark

comment:2 Changed 12 years ago by Adam Peller

Also, the default selection should be positioned near the textbox, if possible, rather than centered on the popup.

comment:3 Changed 12 years ago by haysmark

Our popup API presently obscures that information from the popup actually.

comment:4 Changed 12 years ago by haysmark

I take that back. Someone added a Tooltip hack into the popup code that would enable this to work.

comment:5 Changed 12 years ago by haysmark

Status: newassigned

Changed 12 years ago by haysmark

Attachment: 4714.patch added

Fixes #4714. TimePicker? highlights the currently selected option. The currently selected option appears adjacent to the TextBox? instead of in the middle.

comment:6 Changed 12 years ago by haysmark

Cc: Adam Peller added

Adam if you would commit this that would expedite getting #4176 fully working.

comment:7 Changed 12 years ago by haysmark

I mean #4716.

comment:8 Changed 12 years ago by Adam Peller

Mark, this patch doesn't look right to me. It only works for values on the hour. Frankly, I liked the selection in the middle than adjacent to the box. Not sure if that was intended for the user or if it's more efficient to code?

comment:9 Changed 12 years ago by haysmark

Ok, so I can look into getting it to highlight non-hour values. But are you saying you want the TimePicker? to appear on top of the textbox?

comment:10 Changed 12 years ago by Adam Peller

I'm not sure we should mess with the positioning at this point. And the objective would be to keep it from overlapping with the textbox...

but for the purposes of this ticket, I think the selection must reflect the state of the value. Not sure how you'd do that if it was fractional (e.g. 3:05) But to have 3:30 and highlight 3:00 is definitely misleading. hmmm

Ideally, one would be able to bring up the popup and easily choose the same value. I'd say that the current value ought to be either centered or near the textbox. Probably best to jump on IRC and run this by some folks like dante and wildbill.

Changed 12 years ago by haysmark

Attachment: 4714.2.patch added

Fixes #4714. TimePicker? highlights the currently selected option.

comment:11 Changed 12 years ago by haysmark

So here is a smaller, cleaner patch to highlight the selected option.

comment:12 Changed 12 years ago by Adam Peller

Resolution: fixed
Status: assignedclosed

(In [10916]) Ah, simple and elegant :) Thanks, haysmark. Fixes #4714

comment:13 Changed 12 years ago by Adam Peller

(In [10971]) Some reductions. Refs #4714

comment:14 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.