Opened 14 years ago

Closed 14 years ago

Last modified 12 years ago

#468 closed defect (fixed)

Menu2 leaves clicked item highlighted in FF/Mozilla

Reported by: cris@… Owned by: anonymous
Priority: high Milestone:
Component: Widgets Version: 0.2
Keywords: Cc: cris@…
Blocked By: Blocking:

Description

For example in test_Menu2.html, go into a submenu and click on a menu item. This may be easiest to see if you _don't_ pick the first menu item.

Then bring up the context menu again. When the submenu opens up, in Mozilla/FF you will see the clicked node highlighted before moving the mouse over it.

This patch seems to resolve the issue.

Index: Menu2.js
===================================================================
--- Menu2.js    (revision 3161)
+++ Menu2.js    (working copy)
@@ -533,6 +533,7 @@
                        }

                }else{
+                        this.unhighlightItem();
                        this.parent.closeAll();
                }


Change History (6)

comment:1 Changed 14 years ago by bill

Resolution: fixed
Status: newclosed

I remember seeing this problem but now I followed your instructions above and I can't reproduce it. Is it still happening for you on the latest build?

comment:2 Changed 14 years ago by cris@…

Resolution: fixed
Status: closedreopened

Hi Bill,

The bug is still there today (March 6) in the tests on the Dojo web site. Go all the way down the menu tree and select "Four", then come back to the menu again.

comment:3 Changed 14 years ago by bill

Cc: cris@… added
Milestone: 0.3release

What browser are you using?

I just tried the link below on Win2000 running FF 1.5.1 and IE 6.0. Didn't reproduce.

http://archive.dojotoolkit.org/nightly/tests/widget/test_Menu2.html

Maybe it's a timing issue. I clicked "four".

comment:4 Changed 14 years ago by anonymous

Hi Bill,

FireFox? 1.0.6, Mozilla 1.7.

Yes, that's the same URL. It's very reproducible on Windows and on Linux. Possibly some browsers fire mouseout events when hiding an element that has the mouse over it, but others don't. That could create a browser dependency like this one may be.

comment:5 Changed 14 years ago by bill

Resolution: fixed
Status: reopenedclosed

Fixed in rev 3232.

comment:6 Changed 12 years ago by (none)

Milestone: 0.3release

Milestone 0.3release deleted

Note: See TracTickets for help on using tickets.