Opened 12 years ago

Closed 11 years ago

#4650 closed enhancement (fixed)

DnD: Allow dndItems that are not a direct descendent of Source

Reported by: guest Owned by: Eugene Lazutkin
Priority: high Milestone: 1.2
Component: DnD Version: 0.9
Keywords: Cc: michelle.dsouza@…
Blocked By: Blocking:

Description (last modified by Eugene Lazutkin)

Drag and drop only works when the dnd items are direct children of a dnd Source. Here is a slight modification of part of the test_dnd.html file that shows the non working behaviour:

<div dojoType="dojo.dnd.Source" jsId="c2" class="container">

<div>

<div class="dojoDndItem">Item <strong>X</strong></div> <div class="dojoDndItem">Item <strong>Y</strong></div> <div class="dojoDndItem">Item <strong>Z</strong></div>

</div>

</div>

Change History (4)

comment:1 Changed 12 years ago by Eugene Lazutkin

Milestone: 1.1
Status: newassigned

Need more info in the ticket on possible use cases.

comment:2 Changed 12 years ago by guest

One case where I'd like to use drag and drop is a table which contains items some of which can be moved around. Here is a simplified version of the markup:

<table dojoType="dojo.dnd.Source"><tbody>
 <tr> 
  <td>
   <div class="dojoDndItem"> Item 1</div>
   <div> Item 2</div>
   <div class="dojoDndItem"> Item 3</div>
  </td>
  <td>
   <div class="dojoDndItem"> Item 4</div>
  </td>
 </tr>
 <tr>
  <td>
   <div class="dojoDndItem"> Item 5</div>
   <div class="dojoDndItem"> Item 6</div>
  </td>
 </tr>
</tbody></table>

comment:3 Changed 11 years ago by bill

Milestone: 1.11.2

Move all milestone 1.1 tickets to 1.2, except for reopened tickets and tickets opened after 1.1RC1 was released.

comment:4 Changed 11 years ago by Eugene Lazutkin

Description: modified (diff)
Resolution: fixed
Status: assignedclosed

Duplicate of #6847. Already implemented.

Note: See TracTickets for help on using tickets.