Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4644 closed defect (worksforme)

IE7 Crashes when clearing console

Reported by: guest Owned by: Adam Peller
Priority: high Milestone: 1.0
Component: General Version: 0.9
Keywords: Cc: jayant.b.sai@…
Blocked By: Blocking:

Description

I have a simple HTML page, code below. When I open it in IE7, click the 'Clear' link on the console, its fine.

I then enter a JavaScript? statement (example 'window', 'document') & hit enter, it evaluates and shows the output to the console. But now clicking the 'Clear' link crashes IE7.

<html>
 <head>
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
    <title>Crash</title>
    <script type="text/javascript">djConfig = { isDebug:true }</script>
    <script type="text/javascript" src="js/dojo/dojo/dojo.js"></script>
  </head>
  <body>
  </body>
</html>

Change History (5)

comment:1 Changed 12 years ago by Adam Peller

Milestone: 1.0
Owner: changed from anonymous to Adam Peller

perhaps we should upgrade firebug lite?

comment:2 Changed 12 years ago by James Burke

It might be worth revisiting this after the patch to #4589 has been applied? I'm not sure if it will make a difference, but I haven't looked at the patch.

comment:3 Changed 12 years ago by Adam Peller

Resolution: worksforme
Status: newclosed

Hmm... I take it back. Seems like firebug-lite hasn't been updated.

But I tried this and cannot reproduce the error (with #4589, didn't try prior to that) In the forum, I think you said something about using a tool from one of the MS developers. Perhaps there's something in your config that still triggers the problem?

comment:4 Changed 12 years ago by guest

Actually I tried this on 3 different machines and I was able to reproduce the problem, given I am still using 0.9.0 final: #1: (Mine) details on IE7 in forum posting (http://dojotoolkit.org/forum/dojo-core-dojo-0-9/dojo-core-support/ie7-crashes-when-using-console) #2: IE7 + IE Developer toolbar #3: Plain vanilla IE7

Jayant

comment:5 Changed 12 years ago by Adam Peller

ok, please give the trunk a try. re-open if you can still see the problem. thanks

Note: See TracTickets for help on using tickets.