Opened 12 years ago

Closed 11 years ago

#4615 closed defect (invalid)

[demos] Module loading locks up browser

Reported by: guest Owned by: dante
Priority: high Milestone: 1.2
Component: General Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by dante)

Steps to recreate the problem: 1.) Open http://dojotoolkit.org/demos/email-using-0-9 and cnn.com in two tabs. 2.) Reload both tabs. 3.) Try switching btwn tabs while the Dojo demo is loading.

On FF 2, you won’t be able to switch tabs until Dojo is done loading modules presumably b/c the browser is locked. In IE7, you will get an unspecified error on Line 20 when you try to switch tabs.

Again this works smoothly in FF 3 and Opera 9.5

Change History (5)

comment:1 Changed 12 years ago by Tom Trenka

As a note, this is a reproducable bug first mentioned at Ajaxian; not sure what can be done about it but since it's reproducable, I asked the poster (first name Les) to file.

comment:2 Changed 12 years ago by James Burke

This can be fixed if the email demo uses a custom build, or uses an xdomain/CDN build instead of loading the source from archive.dojotoolkit.org. I can appreciate it makes it hard to get the "latest" code out on the demo, but we probably want a code snapshot for anything referenced on the web site.

comment:3 in reply to:  2 Changed 12 years ago by dante

see #4666

comment:4 Changed 11 years ago by dylan

Milestone: 1.2
Owner: changed from anonymous to dante
Summary: Module loading locks up browser[demos] Module loading locks up browser

comment:5 Changed 11 years ago by dante

Description: modified (diff)
Resolution: invalid
Status: newclosed

nothing to fix here? solution is to use layers and builds, and there is lots of optimization talk in various blogs and books to cover fixing this.

Note: See TracTickets for help on using tickets.