Opened 12 years ago

Closed 12 years ago

#4588 closed defect (fixed)

Context menu open throws an Exception on FF2 and FF3 when focus is in a text field

Reported by: simonjb Owned by: alex
Priority: high Milestone: 1.0
Component: Dijit Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

To reproduce:

  1. open dijit/tests/test_Menu.html
  2. click in the "top-left" text field to give it focus
  3. right click
  4. Exception... "'Permission denied to get property HTMLDivElement.parentNode' when calling method: [nsIDOMEventListener::handleEvent]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "<unknown>" data: no

Change History (3)

comment:1 Changed 12 years ago by simonjb

Summary: Context menu open throws an Exception on FF2 when focus is in a text fieldContext menu open throws an Exception on FF2 and FF3 when focus is in a text field

comment:2 Changed 12 years ago by bill

Owner: set to alex

Presumably due to #4307. Alex, we really need this fix ASAP, or will have to rollback your change.

comment:3 Changed 12 years ago by bill

Resolution: fixed
Status: newclosed

Working now, presumably fixed along with #4307.

Note: See TracTickets for help on using tickets.