Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4585 closed enhancement (fixed)

DnD Unexpected sorting with dropping in same source and no insertion point

Reported by: guest Owned by: Eugene Lazutkin
Priority: high Milestone: 1.0
Component: DnD Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

When you drop an element within the same source that it originated in, it will move to the bottom of the list if you drop outside the list of elements but within the source div.

Example: /dojo-release-0.9.0/dojo/tests/dnd/test_dnd.html

Drag Item Alpha in Source 3 to the right until your mouse is to the right of the purple selection indicator, but still within the source block.

Release the item (drop).

Item Alpha now appears at the bottom of the list.

The expected behavior here is that the Item Alpha would remain in its original location. Only elements brought in from foreign sources should move to the bottom of lists when no insertion point is provided.

Change History (7)

comment:1 Changed 12 years ago by guest

left off email : sarkasm@… if more info is needed.

comment:2 Changed 12 years ago by Eugene Lazutkin

Milestone: 1.0
Status: newassigned
Type: defectenhancement

Actually what you described as the bug is the intended behavior. But your "expected behavior" seems reasonable. I am changing this ticket from "defect" to "enhancement".

comment:3 Changed 12 years ago by Eugene Lazutkin

Milestone: 1.01.1

comment:4 Changed 12 years ago by Eugene Lazutkin

Resolution: fixed
Status: assignedclosed

(In [11083]) dnd: modified the behavior of the drop in case of moving items withing a source, fixes #4585, thx sarkasm for the suggestion.

comment:5 Changed 12 years ago by bill

Milestone: 1.11.0

comment:6 Changed 12 years ago by Eugene Lazutkin

Milestone: 1.01.0.1

comment:7 Changed 12 years ago by bill

Milestone: 1.0.11.0
Note: See TracTickets for help on using tickets.