Opened 12 years ago

Closed 12 years ago

#4564 closed defect (invalid)

Editor inserts extra chacter at end

Reported by: guest Owned by: liucougar
Priority: high Milestone:
Component: Editor Version: 0.9
Keywords: editor richtext extra_character Cc:
Blocked By: Blocking:

Description

(by Mike Wilcox) This is actually in the RichText?.js, although technically, it may be in the html component, I'm not sure where the bug comes from.

We are using the editor as email, so the getValue was being sent through such channels. The result had an invalid unicode character at the end. It would be: =EF=BF=BD or (IIRC): U-0000FFDF

Because I'm not sure how this extra character is getting in there, I can't offer a solution. There is a workaround however. When creating the editor, give it this extra parameter: contentPostFilters: [function(str){ return str.substring(0, str.length-1); }], ...this will strip the last character from the value.

Change History (1)

comment:1 Changed 12 years ago by Adam Peller

Resolution: invalid
Status: newclosed

please attach information needed to reproduce this problem

Note: See TracTickets for help on using tickets.