Opened 7 years ago

Closed 7 years ago

Last modified 3 years ago

#4543 closed defect (worksforme)

ComboBox displays More/Previous choices option when there are none.

Reported by: guest Owned by: haysmark
Priority: high Milestone:
Component: Dijit - Form Version: 0.9
Keywords: Cc:
Blocked by: Blocking:

Description

I've found that the More/Previous prompt appears anytime The user types in text which is not found in the FilteringSelect or ComboBoxes, regardless to the lack of more or previous options. It is somewhat confusing to prompt our user to select More/Previous choices when there are none.

I've found that if I click the drop-down, then begin typing, the box doesn't show up. I'm not sure if that is a bug or not, but it is curious.

Example Code:

<select id='Area' name='Area'
	    dojoType='dijit.form.ComboBox'
	    autocomplete="true"
            size="40"  
            onChange=AreaChanged>
	      <option value='' selected='selected'></option>
</select>

The preference would be to only show the More/Previous prompt when there is a chance of moving to more or previous choices.

Change History (3)

comment:1 Changed 7 years ago by doughays

  • Owner set to haysmark

comment:2 Changed 7 years ago by haysmark

  • Resolution set to worksforme
  • Status changed from new to closed

Can't reproduce, working with [10706].

If you use the ComboBox in the above example, you get a ComboBox with one item that is blank. There are no previous/more choices options.

If you type text into the ComboBox, you simply get no popup because there are 0 matches.

comment:3 Changed 3 years ago by bill

  • Component changed from Dijit to Dijit - Form
Note: See TracTickets for help on using tickets.