Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#4542 closed defect (fixed)

invalid values in numbertextbox go away on blur

Reported by: Douglas Hays Owned by: Douglas Hays
Priority: high Milestone: 1.0
Component: Dijit - Form Version: 1.0
Keywords: Cc:
Blocked By: Blocking:

Description

Enter a bad value in a numbertextbox and then tab away. The value is replaced by "". This appears to be a regression caused by [10539].

Change History (2)

comment:1 Changed 12 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [10603]) Fixes #4542. References #4422. Removed value from _FormWidget attributeMap since it is handled specially. Added check for invalid values to format() and filter(). Added this.filter to getTextValue() so that trim works on object value types.

comment:2 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.