Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#4539 closed defect (wontfix)

FilteringSelect: it takes two down arrows to get

Reported by: ptbrunet Owned by: haysmark
Priority: high Milestone: 1.0
Component: Dijit - Form Version: 0.9
Keywords: Cc: brunet@…
Blocked By: Blocking:

Description

Go to http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/test_FilteringSelect.html and tab down to a FilteringSelect widget, clear out all the data, when the list appears notice that it takes two presses of the down arrow until you are actually in the list. This will be confusing for a screen reader user.

Change History (4)

comment:1 Changed 12 years ago by haysmark

Pete, I can't reproduce this in any browser. Are you referring to the FilteringSelect? with the blank menu item, i.e. #4537?

comment:2 Changed 12 years ago by ptbrunet

Mark, This is what I am seeing with today's dojo build using

http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/test_FilteringSelect.html

Tab to the first FilteringSelect, press downarrow, the box appears, press downarrow again, the first item is chosen.

The FF2/3 address bar works like the FilteringSelect. I will ask Aaron Leventhal, the Mozilla a11y architect, what he thinks about the current keyboard behavior of the FF2/3 address bar.

comment:3 Changed 12 years ago by ptbrunet

Resolution: wontfix
Status: newclosed

From Aaron Leventhal regarding the similar behavior of the FF2/3 address bar:

I'm not sure why the first down arrow doesn't select the first item. But, I will say that I think users can figure out what's going on either way. I've never heard anyone mention it before. I think it's fine to keep it this way for Firefox 3.

Closing based on Aaron's comments.

comment:4 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.