Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4538 closed defect (fixed)

Popup appears in wrong place when viewport small

Reported by: guest Owned by: haysmark
Priority: high Milestone: 1.0
Component: Dijit Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

FireFox2, Mac oS X. Not tested in IE

HOW TO REPRODUCE:

Go to http://82.230.65.68:31416/~fred/dojo/fred_samples/bug_005.html There are 4 date fields Click on each of them

RESULT:

Only the first one displays a popup below The other popups have a top of 0px

EXPECTED RESULT:

All text fields display a menu *under* them when you click on them

COMMENT:

This is a regression, the popups are ok with aol cdn 0.9 release

Attachments (1)

4538.html (939 bytes) - added by bill 12 years ago.
same as link specified above, but place as sibling of dojo directory

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by guest

Original reporter here.

The have been no comment/ack or nack on that bug in the last 5 days.

I have further tested and it is Firefox specific. Occurs on:

Firefox 2 OSX, Firefox 2 XP, GranParadiso? OSX

Does not occur on:

IE6 XP, Safari OSX

Changed 12 years ago by bill

Attachment: 4538.html added

same as link specified above, but place as sibling of dojo directory

comment:2 Changed 12 years ago by bill

Milestone: 1.0
Owner: set to haysmark
Priority: normalhigh
Summary: DateTextField popup appear in the wrong placePopup appears in wrong place when viewport small

Thanks for the testcase. Looks like a bug. Problem is that the dijit._getViewport() (called by djit._place()) returns height=99px, regardless of the actual browser window size. (99px is the height of the document). Mark, looks like a problem with your recent changes to place.js in [10345]. That change needs to be reverted.

comment:3 Changed 12 years ago by bill

PS: I meant that both [10334] and [10345] need to be reverted. Since the document can be much bigger or much smaller than the viewport, can't assume that viewport size is min(viewport, document). Not sure what to do about subtracting scroll bar size; needs some more research I.

comment:4 Changed 12 years ago by haysmark

It's the DTD that breaks the getViewport code actually. If you remove the doctype it works.

Patch forthcoming.

comment:5 Changed 12 years ago by haysmark

Status: newassigned

comment:6 Changed 12 years ago by Douglas Hays

Resolution: fixed
Status: assignedclosed

(In [10680]) Fixes #4538. Proxy commit for haysmark. Added support for strict DTD in FF dijit.getViewport calls (was returning document size in strict mode).

comment:7 Changed 12 years ago by bill

(In [10695]) Tests for dijit. getViewport(). Refs #4538.

Note: See TracTickets for help on using tickets.