Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#4467 closed defect (fixed)

RadioButton: cutoff on FF

Reported by: bill Owned by: Sam Foster
Priority: high Milestone: 1.0
Component: Dijit - Form Version: 0.9
Keywords: ff css Cc: dante
Blocked By: Blocking:

Description

In themeTester.html on the "Form Feel" tab, the checkboxes look fine but the radio buttons are cutoff. No idea why... the CSS looks the same. Sam, can you take a look?

Problem's been there since the 0.9 release.

Attachments (1)

checkbox_4467_sfoster_20071015.patch (440 bytes) - added by Sam Foster 12 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 12 years ago by Sam Foster

Cc: dante added
Keywords: ff css added
Status: newassigned

checkbox_4467_sfoster_20071015.patch adds a fix for this issue. Its a little voodoo though. The issue is to do with how vertical-align middle is handled, and the height of the line-box - which I wont claim to understand fully. Setting to inline-box and giving height creates enough room for the background image to show reliably. The same effect is achieved by setting margin:2px 0; .. but I'm more nervous about margin having side-effects somewhere.

Changed 12 years ago by Sam Foster

comment:2 Changed 12 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [10888]) Fixes #4467: RadioButton/CheckBox? cutoff on FF. Basic issue dealt with height property being ignored on the <input> since it was display:inline. Thanks sfoster for finding that.

comment:3 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.