Opened 12 years ago

Closed 11 years ago

#4421 closed defect (wontfix)

[cla][patch] Safari and dijit.Editor

Reported by: guest Owned by: Douglas Hays
Priority: high Milestone: 1.2
Component: Editor Version: 0.9
Keywords: Cc: hannes.wyss@…
Blocked By: Blocking:

Description (last modified by Adam Peller)

Hi there!

I posted some Patches back in 2006 to get Editor2 working with Safari - and now I'm at it again for dijit.Editor :)

So far, I've managed to get Font-Formatting and Alignment working, mainly by preventing Safari from losing the selection on click.

I've also implemented a Html-Source editing plugin, which I'm happy to share if you're interested. For that I needed to fix RichText#replaceValue?() - is there any particular reason why there is no catch-all that just hands the call off to setValue?

Finally I had an issue where Safari would only display the text-value, with all html-formatting stripped.

I'm attaching a patch with these three changes.

thanks for any feedback you can give me

cheers, Hannes

Attachments (1)

dojo.editor.patch (6.6 KB) - added by guest 12 years ago.

Download all attachments as: .zip

Change History (8)

Changed 12 years ago by guest

Attachment: dojo.editor.patch added

comment:1 Changed 12 years ago by dylan

Milestone: 1.0
Owner: changed from anonymous to alex
Summary: Safari and dijit.Editor[cla][patch] Safari and dijit.Editor

cla confirmed, alex, please take a look at the patch.

comment:2 Changed 11 years ago by Adam Peller

Hannes, sorry this has gotten stale again. Are these patches still required for Safari 3? We've since dropped support for Safari 2.

comment:3 Changed 11 years ago by dylan

Milestone: 1.11.2

mass move of editor issues to 1.2.

comment:4 Changed 11 years ago by Adam Peller

Component: GeneralEditor
Description: modified (diff)

still don't know if any of this is needed in the Safari 3+ world. Without a confirmation we should probably close as wontfix.

comment:5 Changed 11 years ago by Adam Peller

Owner: changed from alex to Douglas Hays

Some of this patch appears to already be in trunk. Doug can you look at some of the remaining parts like the mousedown event handler? Clearly, if it's specific to 2.0.4, we should wontfix.

comment:6 Changed 11 years ago by bill

Type: enhancementdefect

comment:7 Changed 11 years ago by Douglas Hays

Resolution: wontfix
Status: newclosed

I tested with Safari 3.1.2 on WinXP and these problems appear to be fixed.

Note: See TracTickets for help on using tickets.