Opened 12 years ago

Closed 12 years ago

#4403 closed defect (duplicate)

dojo.formToObject doesnt understand name="someArray[]"

Reported by: tk Owned by: James Burke
Priority: high Milestone: 1.0
Component: IO Version: 0.9
Keywords: formToObject Cc: blaine@…
Blocked By: Blocking:

Description

if you have a form with 2 inputs with name="someArrayInPHP[]" you will only ever get the last value in the queryObject...

verified this is not a problem with XHR by doing the following.

var test[0] = 5; var test[1]=6; dojo.xhrGet({url:'test.php', content: {blah: test}, handleAs: 'text, handle: function(r,i) { alert(r); }});

It will output properly (?blah=5&blah=6) but if you use form: formId; you only get blah=6...

I helped BladeSling? (cc'd on this ticket) troubleshoot the problem, I didnt have time to look at fixing it tonight though. Setting priority = high and severity = major because this is a common use of forms to build arrays in PHP and other server side languages.

-Karl

Change History (1)

comment:1 Changed 12 years ago by tk

Resolution: duplicate
Status: newclosed

Duplicate of #4259

Note: See TracTickets for help on using tickets.