Opened 12 years ago

Closed 12 years ago

#4399 closed enhancement (fixed)

Rearrange base dojo.js to allow for smaller loader code

Reported by: James Burke Owned by: James Burke
Priority: high Milestone: 1.0
Component: Loader Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

Move code out of _base/_loader for things that are strictly not loader related. Still keep them as part of _base, but allow for building a smaller stand-alone loader.

Change History (3)

comment:1 Changed 12 years ago by James Burke

(In [10451]) Refs #4399. Rearrange code to separate loader concerns from other things. Ends up with a slightly smaller dojo.js too. Still a bit more to do on it, but this tested well.

comment:2 Changed 12 years ago by James Burke

(In [10456]) Refs #4399. Info on how to apply and create a custom_rhino.jar patch.

comment:3 Changed 12 years ago by James Burke

Resolution: fixed
Status: newclosed

Closing this for now. Tries some different shrinksafe variable naming approach and tries using a closure for the content of loader_xd.js, but neither one resulted in an appreciable difference (20 to 100 bytes, in some case, size was larger). The "just loader" code (the stuff in _base/_loader) built and gzipped comes to be (in bytes):

  • 4917 dojo.js
  • 8091 dojo.xd.js

The xd size is a bit larger than I would like, but I'm out of quick fixes.

Note: See TracTickets for help on using tickets.