Opened 12 years ago

Closed 12 years ago

#4392 closed defect (fixed)

Add custom attributes to form-widget

Reported by: guest Owned by: Adam Peller
Priority: high Milestone: 1.0
Component: Dijit Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

I have a form-widget like so:

<form dojoType="dijit.form.Form" action="/save/here/" method="post">

which is after parsing and replacing the following, it looses the action attribute :-( but noone wants that i guess

<form dojoattachevent="onsubmit:_onSubmit" dojoattachpoint="containerNode" style="" widgetid="ratingForm" method="post">

the attached patch adds all the attributes, but the "dojotype" i actually copied that from 0.4 and made it work.

Attachments (1)

Form_add_custom_attribs.diff (828 bytes) - added by guest 12 years ago.
adds all form attributes back in (wolfram@…)

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by guest

adds all form attributes back in (wolfram@…)

comment:1 Changed 12 years ago by guest

somehow my name/email wolfram@… got lost up there, CLA is signed

comment:2 Changed 12 years ago by bill

Milestone: 1.0
Owner: set to Adam Peller

Peller is in the process of redoing how attributes are copied so I'm assigning this to him. BTW, your patch is clever but the problem is that it doesn't support programmatic creation like

new dijit.form.Form( { action: "/save/here" } );

That's why we always let the parser read in the attributes rather than trying to access them directly from the srcNodeRef.

comment:3 Changed 12 years ago by Adam Peller

Resolution: fixed
Status: newclosed

(In [10550]) Copy over native HTML FORM attributes. Refs #3058. Fixes #4392

Note: See TracTickets for help on using tickets.