Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4376 closed defect (fixed)

IE: wai.js causes a long horizontal scrollbar in RTL direction

Reported by: Adam Peller Owned by: Becky Gibson
Priority: high Milestone: 1.0
Component: Accessibility Version: 0.9
Keywords: bidi Cc: yinjun@…, hwcdl@…
Blocked By: Blocking:

Description

See Justin's patch (attached) Looks harmless enough, but I don't really understand what side effects this might have.

Attachments (1)

dijit-bidi-fix-wai.js-10425.patch (538 bytes) - added by Adam Peller 12 years ago.
Fix from Justin Yin (IBM, CCLA)

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by Adam Peller

Fix from Justin Yin (IBM, CCLA)

comment:1 Changed 12 years ago by Adam Peller

Cc: yinjun@… added

comment:2 Changed 12 years ago by Becky Gibson

looks simple enough but I couldn't reproduce the problem so didn't want to check in. Can someone with more CSS knowledge review?

comment:3 Changed 12 years ago by Adam Peller

Cc: hwcdl@… added

Evan/Justin?, we can not reproduce the problem. Seems like the div in question is not visible, so the -999 should be harmless? Can you show a case where we need to apply this patch? And what does 50% do? thanks

comment:4 Changed 12 years ago by Becky Gibson

Resolution: fixed
Status: newclosed

(In [10793]) fixes #4376. I removed the left property altogether since top:-999px should be enough to move off screen and out of view. added height:5px to make sure it has minimal size incase of stylesheet that sets height of all divs to 100% (thanks sfoster!)

comment:5 Changed 12 years ago by Adam Peller

Keywords: bidi added
Note: See TracTickets for help on using tickets.