Opened 12 years ago

Closed 11 years ago

#4339 closed defect (worksforme)

Dialog: when the horizontal and vertical scrollbar both exist in firefox window, Can not scroll the vertical scrollbar to its end when dojit dialog showing

Reported by: guest Owned by:
Priority: high Milestone: 1.3
Component: Dijit Version: 0.9
Keywords: dialog scroll Cc:
Blocked By: Blocking:

Description (last modified by Douglas Hays)

if the content in page is overflowed, and the vertical and horizontal scrollbar also exist. trigger a dialog to show, then drag the vertical scrollbar down, seems it can scroll infinitely and can not touch its end.

Change History (3)

comment:1 Changed 12 years ago by bill

Milestone: 2.0
Summary: when the horizontal and vertical scrollbar both exist in firefox window, Can not scroll the vertical scrollbar to its end when dojit dialog showingDialog: when the horizontal and vertical scrollbar both exist in firefox window, Can not scroll the vertical scrollbar to its end when dojit dialog showing

comment:2 Changed 12 years ago by alex

Milestone: 2.01.3

Milestone 2.0 deleted

comment:3 Changed 11 years ago by Douglas Hays

Description: modified (diff)
Resolution: worksforme
Status: newclosed

Using revision [14665] from the latest trunk, I was unable to recreate this.
Starting with dijit/tests/test_Dialog.html, I added style="width:150%;" to the first <h1> tag to add the horizontal scrollbar. I clicked the "Show Dialog" button, and then scrolled the vertical scrollbar down to the bottom. I'm testing with Firefox 2.0.0.16 on WinXP. Please provide a test file if the problem is still recreatable with the latest nightly.

Note: See TracTickets for help on using tickets.