Opened 12 years ago

Closed 12 years ago

#4334 closed defect (wontfix)

dojo 0.9: dojo.fx.wipeIn() and dojo.fx.wipeIn() cross browser issues

Reported by: guest Owned by: Bryan Forbes
Priority: high Milestone:
Component: fx Version: 0.9
Keywords: Cc: hannes.wyss@…
Blocked By: Blocking:

Description

In order for a div to properly wipe in and out on various platforms I needed to set its display style to "block" in strategic locations. I'm aware (or rather I presume) that this prevents display:inline elements from being displayed properly, but afaik there is no way of reliably setting the height of an inline element anyway...

Patch (Works for me TM) attached.

Thanks in advance!

Attachments (2)

dojo.fx.patch (780 bytes) - added by guest 12 years ago.
wipeInOut.html (1.2 KB) - added by guest 12 years ago.

Download all attachments as: .zip

Change History (11)

Changed 12 years ago by guest

Attachment: dojo.fx.patch added

comment:1 Changed 12 years ago by guest

I forgot: Tested on Linux (Firefox 2.0.0.6, Opera 9.23, Konqueror 3.5.7), Mac OS X (Safari 2.0), Windows XP (IE6, IE7)

comment:2 Changed 12 years ago by alex

who flied this? Is there a CLA on file?

comment:3 Changed 12 years ago by bill

Component: Generalfx
Owner: changed from anonymous to Bryan Forbes

The bug description is rather strange. You said "In order for a div to properly wipe in and out on various platforms I needed to set its display style to "block"", but a <div> is already block.

Wipe in and wipe out are only supposed to work on block level elements. I don't consider that a bug, just a requirement.

comment:4 in reply to:  2 Changed 12 years ago by guest

Replying to alex:

who flied this? Is there a CLA on file?

yes, you should have my CLA, look for hannes<dot>wyss<at>gmail<dot>com

comment:5 in reply to:  3 Changed 12 years ago by guest

Replying to bill:

The bug description is rather strange. You said "In order for a div to properly wipe in and out on various platforms I needed to set its display style to "block"", but a <div> is already block.

yes, but if you look at the patch you'll see that the existing code actually sets display = "". And afaics that just doesn't work on several platforms. It's possible that my problem has to do with the block's display attribute being set to "none" initially - the block is invisible, and wiped in later. An example (dojo 0.3, being updated to 0.9) is here: http://www.davaz.com/en/personal/home/pretty

an aside: could you put me (hannes<dot>wyss<at>gmail<dot>com) onto the CC-list? I failed to do so when filing the bug initially and I can't find a way to do it now?

comment:6 Changed 12 years ago by Adam Peller

Cc: hannes.wyss@… added

comment:7 Changed 12 years ago by bill

OK, please attach a small test case against 0.9, using the "attach file" button, and let us know what browser was having problems with

s.display="";

comment:8 Changed 12 years ago by guest

ok, attaching..

Writing the test-case I was able to drill down a bit further; the problem arises from the fact that I've used the div-id to define display:hidden in an external css-file (or, in the case of the test-case, inline), instead of directly writing a style-property into the tag. Setting style.display = "" then sets the display-property to the ids default, which is "hidden".

Not sure if that still qualifies as a bug...

The testcase demonstrates the problem in Firefox 2.0.0.8 and Opera 9.24, both on Linux x86_64

Changed 12 years ago by guest

Attachment: wipeInOut.html added

comment:9 Changed 12 years ago by bill

Resolution: wontfix
Status: newclosed

Ah right, we've had two other bugs about this recently, perhaps from you. It's just a limitation of the system that you can't hide stuff via CSS rules. It's pretty easy to do display="block" in our code but the problem is that things like tables don't work well if you set display to block (on some browsers, anyway).

Note: See TracTickets for help on using tickets.