Opened 12 years ago

Closed 12 years ago

#4326 closed defect (invalid)

Extra page loads with refreshOnShow="true"

Reported by: guest Owned by: mumme
Priority: high Milestone: 1.1
Component: Dijit Version: 1.0
Keywords: refreshOnShow, ContentPane Cc:
Blocked By: Blocking:

Description

When I use refreshOnShow="true" with my ContentPanes? the initial ContentPane? loads 3 times when the page is first displayed. If I omit the refreshOnShow="true" it only loads once. Here's an example:

<div id="mainTabContainer" dojoType="dijit.layout.TabContainer" labelPosition="left-h" style="width: 99%; height: 99%;" tabPosition="left">    
  <div id="tab1" dojoType="dijit.layout.ContentPane"  href="afw?alt=0&section=1&stream=0&all=0" title="General" refreshOnShow="true"></div>
  <div id="tab2" dojoType="dijit.layout.ContentPane"  href="afw?alt=0&section=2&stream=0&all=0" title="Purchases" refreshOnShow="true"></div>
 ...
</div>

http://dojotoolkit.org/forum/dijit-dijit-0-9/dijit-support/extra-page-loads-refreshonshow-true

Change History (6)

comment:1 Changed 12 years ago by mumme

Cc: mumme removed
Owner: set to mumme

comment:2 Changed 12 years ago by mumme

Keywords: refreshOnShow ContentPane added
Milestone: 0.9

comment:3 Changed 12 years ago by bill

Milestone: 0.91.0

We release 0.9 2 weeks ago so the earliest milestone you can set is 1.0. Thanks for fixing this!

comment:4 Changed 12 years ago by Adam Peller

can this be done this week for 1.0?

comment:5 Changed 12 years ago by Adam Peller

Milestone: 1.01.1

mumme said he cannot reproduce this. Can you attach files with specific steps and platform info?

comment:6 Changed 12 years ago by Adam Peller

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.