Opened 12 years ago

Closed 12 years ago

#4321 closed defect (fixed)

InlineEditBox format bug

Reported by: haysmark Owned by: bill
Priority: high Milestone: 1.0
Component: Dijit Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

I open InlineEditBox? to check FilteringSelect? and I find three odd bugs in InlineEditBox? suddenly:

  1. If you load the InlineEditBox? test the inline text has a huge white gap after it.
  2. If you click to edit the text the textbox is not as big as the white space.
  3. If the user enters text that overflows the white space, the text appears ON TOP of the text after the InlineEditBox? and is unreadable. YUCK!

Are these bugs new features? If so, don't we need to go through a deprecation cycle for changes this big? I'm sure our 0.9 users will want to keep the 0.9 behavior where the inline text was in fact inline.

Attachments (1)

bug3.JPG (24.2 KB) - added by haysmark 12 years ago.
Item 3, demonstrating text overflowing instead of inlining like in 0.9.

Download all attachments as: .zip

Change History (8)

Changed 12 years ago by haysmark

Attachment: bug3.JPG added

Item 3, demonstrating text overflowing instead of inlining like in 0.9.

comment:1 Changed 12 years ago by bill

Owner: changed from bill to Douglas Hays

#1 is because the test has a line break after the inline edit box (because of the <hr>) so it's not a bug, but the test file should be improved not to do that.

#2 is a bug. At least by default the edit area should be the same size as the display area.

#3 is definitely a bug.

comment:2 Changed 12 years ago by Douglas Hays

Issue #2 is already covered by #4167. Issues #1 and #3 are because the test file as width:400px on a span. I don't agree with how #1 looks but it is just user styling andnot a bug. #3 is just bad user styling. It should be an inline fieldset encapsulating a block div and then it will be 400px and not overflow past 400px.

comment:3 Changed 12 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [10450]) Fixes #4321. Changed the test_InlineEditBox.html to not just specify a span with fixed width. Changed the InlineEditBox? template to use the srcNodeRef tagname as the domnode (had to add a <span> around the <fieldset> since FF has a bug where <p> cannot have a <div> or <fieldset> as a direct child). Changed _Templated.js reuse the same dummy div instead of reappending it for every widget.

comment:4 Changed 12 years ago by bill

(In [10459]) Rollback [10450]. It breaks IE (see either themeTester.html or test_InlineEditBox.html, both of which get JS errors on load), because you can't have a <div> inside a <p>. Reopens and refs #4321. I think the correct solution is to actually include the original srcNodeRef alongside the generated HTML from the template (and always one or the other is hidden).

comment:5 Changed 12 years ago by bill

Resolution: fixed
Status: closedreopened

comment:6 Changed 12 years ago by Douglas Hays

Owner: changed from Douglas Hays to bill
Status: reopenednew

InlineEditBox? being redesigned by bill

comment:7 Changed 12 years ago by bill

Resolution: fixed
Status: newclosed

OK, I think this is fixed in dijit.InlineEditBox? with all my recent checkins.

Note: See TracTickets for help on using tickets.