Opened 12 years ago

Closed 12 years ago

#4310 closed defect (fixed)

closed TitlePane opens when setContent() is called

Reported by: guest Owned by: bill
Priority: high Milestone: 1.1
Component: Dijit Version: 0.9
Keywords: TitlePane Cc:
Blocked By: Blocking:

Description

Consider the following example:

var d = new dijit.TitlePane?({title: "test", open:false}, document.createElement("div")); d.setContent("hi"); document.body.appendChild(d.domNode);

The arrow indicates closed, yet the content is still open.

It looks as though the problem is with the setContent, though I didn't debug further than that.

Change History (5)

comment:1 Changed 12 years ago by bill

Milestone: 1.1

comment:2 Changed 12 years ago by bill

Owner: set to mumme

Fredrick, can you take a look at this?

comment:3 Changed 12 years ago by mumme

Owner: changed from mumme to bill

Sorry Bill, I don't have the time needed for dojo just now.

Hopefully things will be brighter in spring 2008

comment:4 Changed 12 years ago by bill

Status: newassigned
Summary: TitlePane initially open when open=falseclosed TitlePane opens when setContent() is called

comment:5 Changed 12 years ago by bill

Resolution: fixed
Status: assignedclosed

(In [11736]) Fixes #4310: closed TitlePane? opens when setContent() is called

Note: See TracTickets for help on using tickets.