Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#4299 closed defect (worksforme)

0.9 [dojox.layout.ContentPane] Instead of loadingMessage, `undefined' appears in browser

Reported by: guest Owned by: mumme
Priority: high Milestone:
Component: DojoX Layout Version: 0.9
Keywords: Cc: hugh@…
Blocked By: Blocking:

Description

When a new tab is created, when using a remote Href to a slow server (in my case, 5+ seconds for a response for a new request..), instead of loadingMessage I get `undefined' showing in the tab until the page begins to load.

I would like to customise my own loadingMessage as well, but for this bug report, this is the code I'm running. When I run it with dijit, I see the loadingMessage <span> defined in dijit.layout.ContentPane?. But in either case, I am not able to customise the loadingMessage when declaring the tab object, so it would be awesome to have a method in dijit/dojox.layout.ContentPane? to allow for that :)

---BEGIN CODE

var callOptions = {

loadingMessage: "Loading...", refreshOnShow:false, executeScripts:true, useVisibility:true, cacheContent:false

}; callOptionsid? = tabName; if (action_onclose) {

callOptionsonClose? = action_onclose;

}

/* dijit.layout.ContentPane? does NOT support executeScripts */

var tab = new dijit.layout.ContentPane? ( callOptions, divNode );

var tab = new dojox.layout.ContentPane?( callOptions, divNode );

tab.setHref(url); tab.title = title; tab.closable = true;

---END CODE

Change History (4)

comment:1 Changed 12 years ago by bill

Owner: changed from Tom Trenka to mumme

comment:2 Changed 12 years ago by mumme

I can't reproduce this even though I set set up my php response page to sleep for 5 sec.

I used dijit/tests/layout/test_TabContainer_remote.html and inserted your code

I replaced your url and title vars with strings and commented out your callOptionsid and if (action_onclose) .... As I have no clue what you want to do with those.

Changing loadingMessage in callOptions above to loadingMessage: "Loading. test.." shows up perfectly fine as a loadingmessage for me.

Would it be possible for you to attach a minimal *complete with all html* testpage to this bug ticket.

Thank you for your help! Regards Fredrik Johansson

comment:3 Changed 12 years ago by mumme

Resolution: worksforme
Status: newclosed

Closing due to lack of response.

comment:4 Changed 9 years ago by bill

Component: DojoxDojoX Layout
Note: See TracTickets for help on using tickets.