Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#4286 closed defect (fixed)

Dijit test "test_Dialog.html" Dialog rendering issues while dragging

Reported by: guest Owned by:
Priority: low Milestone: 1.0
Component: Dijit Version: 0.9
Keywords: Cc: braceta@…
Blocked By: Blocking:

Description

While trying the test_Dialog.html file that comes with dojo 0.9 release I've notice this:

If you try to open the modal Dialog widget (provided by the "Show Dialog" button in the test) the render works fine in Firefox 2.0.0.6. Some strange behavior starts to appear that makes the Dialog "shake". To reproduce:

  • Click the "Show Dialog" button.
  • Drag fast the Dialog over the screen, including edges.
  • Now notice the horizontal scroll bar appearing and some strange behavior appear in the Dialog while dragging.

If you try the same testing page with the "Test slow loading HREF Dialog" button and you don't have PHP on the server side, an even more strange behavior occur. Dragging the Dialog makes oddly resize.

More Info:

  • Dojo version: release 0.9 (final)
  • System: Ubuntu 7.04
  • Browser: Firefox 2.0.0.6

P.S: I will check if I can come up with a patch..At least, I've reported the "bug".. :)

email: braceta@…

Attachments (1)

Dialog.patch (2.0 KB) - added by dante 12 years ago.
patch idea for this ticket, + additional fix idea from inline code

Download all attachments as: .zip

Change History (6)

comment:1 Changed 12 years ago by bill

Milestone: 1.1
Priority: highlow

If you don't have PHP then of course the "show delayed dialog" or any tests that use PHP won't work. Not sure about the dragging thing.

comment:2 Changed 12 years ago by guest

Yes, I know about the PHP issue.. But the problem is not about the loading of the server side content, but instead the dragging/resizing of the widget. .

Ah, by the way, on a faster processor the Dialog doesn't shake.. so probably it is a performance/improvment issue.

comment:3 Changed 12 years ago by dante

Cc: braceta@… added

this wasn't fixed where i thought it had been, but upon further investigation it seems like dnd to top corner of a partially-scrolled window is firing onscroll as it shifts up, which the dialog briefly centers itself, then gets put back where dnd has it positioned. maybe if(dojo.hasClass(dojo.body(),"dndMove")){ return; } in _position is a quick fix.

Changed 12 years ago by dante

Attachment: Dialog.patch added

patch idea for this ticket, + additional fix idea from inline code

comment:4 Changed 12 years ago by dante

Resolution: fixed
Status: newclosed

(In [10591]) fixes #4534 by adding an onEnd connection to the fadeOut animation and fixes #4286 by returning from _position if the Dialog is being dragged around. also adds minor documentation.

comment:5 Changed 12 years ago by bill

Milestone: 1.11.0
Note: See TracTickets for help on using tickets.