Opened 12 years ago

Closed 12 years ago

#4267 closed defect (fixed)

TimePicker bugs in IE6

Reported by: guest Owned by: haysmark
Priority: high Milestone: 1.0
Component: Dijit Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

Using the TimePicker? from the tests, works mostly fine in Firefox, but in internet explorer 6, the graphical selector is extremely wide (approx. 80% of the page) and you are unable to select any times between full hours. For example, you can select 6:00 and 8:00, but not 6:15, 8:30, etc.

Attachments (1)

textbox.jpg (116.2 KB) - added by bill 12 years ago.
works for me

Download all attachments as: .zip

Change History (8)

comment:1 Changed 12 years ago by bill

Component: GeneralDijit
Milestone: 1.0
Owner: changed from anonymous to haysmark

comment:2 Changed 12 years ago by haysmark

See #4133. We're still waiting on itorrey to tundraize TimePicker?. I suspect the lack of style is what causes the width to be too wide in IE6. Other browsers are using the text width and work fine. We just need the Tundra style to determine how big the widget should be.

You can select the between hours items, but for some reason in IE6 only the tiny space character to the far left is receiving the mouse events. The same applies to the hours; you have to click the text.

comment:3 Changed 12 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [10572]) Fixes #4267. Proxy commit for haysmark. Changed _TimePicker template to use a div instead of a fieldset.

comment:4 Changed 12 years ago by guest

Resolution: fixed
Status: closedreopened

Hi, Sorry to re-open the ticket, maybe I'm missing something, but I'm still seeing the exact same behavior in the dijit nightly tests as when I opened the ticket.

http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/test_TimeTextBox.html

Using IE6, I still see the same problem.

Thanks

Changed 12 years ago by bill

Attachment: textbox.jpg added

works for me

comment:5 Changed 12 years ago by bill

Milestone: 1.0

I just tried it, and it's working for me, and also it's working for Mark. I'm running IE6 6.0.2900.2180.xpsp_sp2_gdr.070227-2254. How about you? Attach a screenshot like the one I attached to show what behavior you are seeing.

comment:6 Changed 12 years ago by guest

Sorry for the false alarm, it was a caching issue.

I went back to try again, thinking that maybe I had something cached. So, I did a CTRL-Refresh, and I did see something change... it started showing an "X" next to each textbox. However, other than that, the timepicker issue remained the same.

So I went into browser options and clicked the 'delete files' button. That seems to have done the trick. I can't believe it was still cached... after all the reboots, browser restarts, etc. since way back when. But that fixed it.

Thanks for your efforts.

comment:7 Changed 12 years ago by bill

Milestone: 1.0
Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.