Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#4249 closed defect (fixed)

Combobox: dropdown list too wide on Mail demo

Reported by: bill Owned by: dante
Priority: high Milestone: 1.0
Component: Dijit - Form Version: 0.9
Keywords: mail Cc:
Blocked By: Blocking:

Description

In [10326], on FF2/mac demos/mail.html, the To/Subject? fields are narrow but the drop down is very wide. Screenshot attached.

Note: if there's a bug in Combobox (or code it uses) I want it fixed; it's not sufficient just to work around this problem in the Mail demo.

Attachments (1)

tooWide.png (15.2 KB) - added by bill 12 years ago.
still a little too wide. it's ok to be wide in order to accomodate the width of the text but i don't think that's the issue here?

Download all attachments as: .zip

Change History (12)

comment:1 Changed 12 years ago by bill

Owner: set to Douglas Hays

comment:2 Changed 12 years ago by Douglas Hays

Owner: changed from Douglas Hays to haysmark

comment:3 Changed 12 years ago by bill

Owner: changed from haysmark to dante

OK, Mark explained that the problem is that the mail demo does

... dojoType=dijit.form.Combobox style="width: 100%"

but we aren't supporting the style tag on form elements (as per my request; it's not worth the effort). So let's change the demo to just have a size specified via a CSS rule. After #4250 is fixed (and also #3273 i guess) can maybe add a CSS rule like

.newMessage .dijitInputField { width: 95%}

or something like that.

comment:4 Changed 12 years ago by bill

Keywords: mail added
Owner: changed from dante to haysmark

Mark may have a solution to make width:100% work after all.

comment:5 Changed 12 years ago by haysmark

Owner: changed from haysmark to dante

False alarm.

comment:6 Changed 12 years ago by dante

Resolution: fixed
Status: newclosed

(In [10333]) fixes #4256 - adds link tooltipdialog to editor toolbar, quickly adds a better looking icon to basic sorting-table, and fixes #4249 for the time being - a template patch may come in to allow combobox to be styled inline ...

comment:7 Changed 12 years ago by bill

Resolution: fixed
Status: closedreopened

Hmm, it's still a little too wide, although better than before, at least on FF (not sure whose bug it is). Screen shot attached.

Changed 12 years ago by bill

Attachment: tooWide.png added

still a little too wide. it's ok to be wide in order to accomodate the width of the text but i don't think that's the issue here?

comment:8 Changed 12 years ago by haysmark

The Subject box also has a custom style that you need to remove.

comment:9 Changed 12 years ago by dante

Resolution: fixed
Status: reopenedclosed

(In [10337]) re fixes #4249 (didn't see the combo box dropdown in subject) and fixes #4255 - adding a progress bar (a real one) to the Dialog that "fetches new mail" ...

comment:10 Changed 12 years ago by dante

(In [10338]) refs #4249 - because i'm an idiot.

comment:11 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.