Opened 12 years ago

Closed 12 years ago

#4241 closed defect (fixed)

IE breaks if the props object passed to dojo._mixin is undefined.

Reported by: Tom Trenka Owned by: alex
Priority: high Milestone: 1.0
Component: Core Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

In _base/lang.js, line 73, there's a branch for IE only that looks like this:

var p=props.toString;

The issue is that if somehow the second argument is undefined, props doesn't exist and IE throws the following error:

"toString is null or not an object".

It's not a very common issue (props should never be undefined in the first place) but it's a *very* difficult error to trace.

I'd suggest changing line 72 to:

if(dojo.isIE && typeof(props)!="undefined").

Change History (1)

comment:1 Changed 12 years ago by alex

Resolution: fixed
Status: newclosed

looks like this was fixed in [10585]

thanks sjmiles!

Note: See TracTickets for help on using tickets.