Opened 12 years ago

Closed 11 years ago

#4237 closed defect (worksforme)

Programmatic combo box throws exception with wildcard usage

Reported by: guest Owned by: haysmark
Priority: high Milestone: 1.0.1
Component: Dijit Version: 0.9
Keywords: Combo Box Cc:
Blocked By: Blocking:

Description

Hi,

I encounter problems using the programmatic instantiation of comboboxes. So far, instantiation works fine. However, when I try to filter the dropdown content with a wildcard (just by typing "*") the firefox console reports an "invalid quantifier *". The error is reproducable in the current dijit tests at: http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/test...

(Try typing * in the "combo created by createWidget").

The error does not occur when the ComboBox? is instantiated by the onloadParser using the dojoType attribute on the input element. (ComboBox? #1 in the test)

Can anybody clarify if this is a bug ?

Change History (7)

comment:1 Changed 12 years ago by bill

Milestone: 1.1

comment:2 Changed 12 years ago by bill

Milestone: 1.12.0
Owner: set to haysmark

You shouldn't need to type a *. If you want to get all the values that start with "ca", just type "ca". I suppose that typing * itself doesn't work because it gets converted to a search for "" but not sure if that's worth fixing. Marking as 2.0 for now.

comment:3 Changed 12 years ago by guest

Ok then, but why does it work if the widget is created by the parser and why not if it is created with the "new" operator. Furthermore even if the wildcard is not supposed to work it should not create a javascript execption that pops up to the end-user. At least this should be fixed, otherwise users would be quite confused.

comment:4 Changed 12 years ago by haysmark

Probably should reconsider the use of regular expressions in the 0.9 version of ComboBox?. There have been a lot of tickets like this.

comment:5 Changed 11 years ago by Douglas Hays

Milestone: 2.01.0.1
Resolution: fixed
Status: newclosed

I don't see the error message in the firebug console on 1.0.1 or 1.1 (FF2 on winxp).

comment:6 Changed 11 years ago by Adam Peller

Resolution: fixed
Status: closedreopened

looks like a 'worksforme' rather than a 'fixed'?

comment:7 Changed 11 years ago by Adam Peller

Resolution: worksforme
Status: reopenedclosed
Note: See TracTickets for help on using tickets.