Opened 12 years ago

Closed 12 years ago

#4235 closed defect (wontfix)

Combo Box reset when hitten escape key twice in IE6

Reported by: guest Owned by: Douglas Hays
Priority: high Milestone: 1.0
Component: Dijit Version: 0.9
Keywords: Combo Box Cc:
Blocked By: Blocking:

Description

when the ESC key is pressed twice inside a combobox running in IE6, all comboboxes that are on the screen loose their selected values. The issue is reproducable in current dijit tests.

Change History (2)

comment:1 Changed 12 years ago by bill

Milestone: 1.0
Owner: set to Douglas Hays

comment:2 Changed 12 years ago by Douglas Hays

Resolution: wontfix
Status: newclosed

This is a known "feature" of IE. 2 Esc keys cause a form reset action. It's the same as if there was a Reset button on the page. 1.0 widgets do not support form reset and there's apparently no way to prevent it.

Note: See TracTickets for help on using tickets.