Opened 14 years ago

Closed 14 years ago

Last modified 10 years ago

#4234 closed defect (fixed)

InlineEditBox/DateTextBox: wrong alignment

Reported by: bill Owned by: Douglas Hays
Priority: high Milestone: 1.0
Component: Dijit - Form Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description

In test_InlineEditBox.html on FF2/Mac click the date text box to edit it. alignment of drop down is wrong.

Change History (5)

comment:1 Changed 14 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [10341]) Fixes #4234. Hide the noneditable text before setting focus to the editable text since focusing causes dojo.coords to be invoked.

comment:2 Changed 14 years ago by bill

Resolution: fixed
Status: closedreopened

This checkin makes themeTester not work on IE, so need a different fix. Problem w/hiding the element that has focus and/or focusing on an element that's hidden. Doug is working on a fix; reopening this bug as a reminder.

comment:3 Changed 14 years ago by Douglas Hays

Resolution: fixed
Status: reopenedclosed

(In [10349]) Fixes #4234. Placed the edit widget first in the template so that the popup coords are correct. Added some code so that the user's css styling is better applied to the edit widget.

comment:4 Changed 14 years ago by Douglas Hays

(In [10374]) References #4234. Add zoom:1 back to dijit.css to fix a regression in test_button.html. Thx ttrenka.

comment:5 Changed 10 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.