Opened 12 years ago

Closed 12 years ago

#4228 closed defect (fixed)

[patch]Dropdown positioning wrong in RTL mode

Reported by: bill Owned by: Adam Peller
Priority: high Milestone: 1.1
Component: Dijit Version: 0.9
Keywords: bidi Cc: hwcdl@…
Blocked By: Blocking:

Description

In themeTester.html?test-bidi click the arrow for the Save ComboButton?. Drop down is not aligned with button

Attachments (1)

4228-11767.patch (2.5 KB) - added by Adam Peller 12 years ago.
patch from Wei Huang and Ling Luo (IBM, CCLA)

Download all attachments as: .zip

Change History (9)

comment:1 Changed 12 years ago by Adam Peller

Cc: yinjun@… added

comment:2 Changed 12 years ago by Adam Peller

Keywords: bidi added

comment:3 Changed 12 years ago by Adam Peller

Milestone: 1.1

Notes from Justin Yin (IBM): This defect only happens in Firefox. It is caused by the left-side scrollbar of the button's container. The code for FF in the dojo._abs function only sums all ancestor's "scrollLeft" for the absolute "left" value without considering the left-side scrollbar's width which is not included in "scrollLeft" but is counted in "left". This is really a hard one to be fixed. It seems very difficult to count all left-side scrollbar's width in Firefox.

comment:4 Changed 12 years ago by bill

This may be caused by #5244 although that's an IE6 bug and this is a FF bug.

comment:5 Changed 12 years ago by Adam Peller

Cc: hwcdl@… added; yinjun@… removed

comment:6 Changed 12 years ago by Adam Peller

Summary: Dropdown positioning wrong in RTL mode[patch]Dropdown positioning wrong in RTL mode

Changed 12 years ago by Adam Peller

Attachment: 4228-11767.patch added

patch from Wei Huang and Ling Luo (IBM, CCLA)

comment:7 Changed 12 years ago by Adam Peller

ignore 4228-11767.patch, above. Use patch for #4369 instead.

comment:8 Changed 12 years ago by Adam Peller

Resolution: fixed
Status: newclosed

(In [11944]) Correct DnD/dropdown bidi placement. Fixes #4369, #4228. Also some size reductions. !strict

Note: See TracTickets for help on using tickets.