Opened 12 years ago

Closed 12 years ago

#4203 closed defect (fixed)

On Firefox 2 the context menu may not close on mouse click

Reported by: simonjb Owned by: bill
Priority: high Milestone: 0.9
Component: Dijit Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by simonjb)

To reproduce:

  • open dijit/tests/test_Menu.html
  • open with context menu by right clicking
  • click on the page background to close the menu
  • open with context menu by right clicking
  • click on the page background to close the menu
  • menu does not close

It is possible to close the menu on FF by mousing over the menu (giving it focus) and then clicking on the background to close.

This issue does not present on IE6 or IE7. I've not got a Mac handy to test Safari.

(not sure that this is a 0.9 blocker but I've set it to 0.9 initially -- bill please change as you see fit)

Change History (2)

comment:1 Changed 12 years ago by simonjb

Description: modified (diff)

comment:2 Changed 12 years ago by bill

Resolution: fixed
Status: newclosed

(In [10228]) Fixes #4203: On Firefox 2 the context menu may not close on mouse click

Apparently this bug happened because:

  1. clicking on the blank area of the screen

causes the menu widget to be deselected (IE, the focus manager call _onBlur()) but it doesn't actually remove focus from the MenuItem?.

  1. Then when dijit.focus(menuItem.focusNode) is called, the focus manager

was ignoring it, and not realizing that the Menu had been opened.

  1. Since focus manager thinks that nothing is open it ignores the background click

Patched for now; may want a better solution later.

Note: See TracTickets for help on using tickets.