Opened 12 years ago

Closed 11 years ago

Last modified 8 years ago

#4189 closed defect (fixed)

Button: Most button top/bottom borders are missing in High Contrast mode (FF3)

Reported by: ptbrunet Owned by: Sam Foster
Priority: high Milestone: 1.1.1
Component: Dijit - Form Version: 0.9
Keywords: a11y Cc: brunet@…, wildbill, Becky Gibson
Blocked By: Blocking:

Description (last modified by Becky Gibson)

With your system in High Contrast mode, on FF3 use the button test case, i.e. .../dijit/tests/form/test_Button.html and notice that most of the top and bottom borders are missing. (Also, the buttons are not in the same place as on FF2 and IE.) This was on FF3 3.0a8pre.

To enter High Contrast mode: Start, Settings, Control Panel, Accessibility Options, Display, High Contrast tab, Use High Contrast checkbox. (I used a setting of "High Contrast Black".)

Attachments (4)

4189-ff3highcontrastbuttons.png (50.2 KB) - added by Sam Foster 11 years ago.
High contrast theme tester screenshot (XP, minefield/ff3)
ff_hc_4189.png (17.1 KB) - added by Sam Foster 11 years ago.
FF3/Minefield screenshot of a simple test case in high-contrast mode
button.html (598 bytes) - added by Sam Foster 11 years ago.
reduced test case with just a unstyled button and a 1px border button that reproduces the issue in HC-mode/FF3
4189_buttonBorders_20080319.patch (772 bytes) - added by Sam Foster 11 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 12 years ago by bill

Owner: set to Sam Foster

See similar bug #4188.

comment:2 Changed 12 years ago by Sam Foster

Status: newassigned

I cant reproduce this in FF2, and I cant seem to download a nightly for ff3 from:http://www.mozilla.org/developer/#builds - the windows link is busted. I dont have the necessary tools to build from source. Are we supporting FF3 in its pre-release state? This sounds like a FF bug not a dojo bug if it cant be reproduced elsewhere?

Or perhaps it was already fixed? I'm adding a similar comment to 4188. I'm ready to resolve this as worksforme?

comment:3 Changed 12 years ago by ptbrunet

Sam, I get my FF3 builds from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/

I also suspect this is a FF3 bug. Can you file a bug against them?

I can file it if you want but please send me a good description of the problem.

comment:4 Changed 12 years ago by Becky Gibson

Milestone: 1.01.1

comment:5 Changed 11 years ago by Adam Peller

Resolution: worksforme
Status: assignedclosed

looks ok to me in FF3 beta 3.

comment:6 Changed 11 years ago by Adam Peller

Resolution: worksforme
Status: closedreopened

sfoster can reproduce the problem. Apparently, using the a11y=true to get the theme on a Mac isn't enough, you really need to use the control panel.

Changed 11 years ago by Sam Foster

High contrast theme tester screenshot (XP, minefield/ff3)

Changed 11 years ago by Sam Foster

Attachment: ff_hc_4189.png added

FF3/Minefield screenshot of a simple test case in high-contrast mode

Changed 11 years ago by Sam Foster

Attachment: button.html added

reduced test case with just a unstyled button and a 1px border button that reproduces the issue in HC-mode/FF3

comment:7 Changed 11 years ago by Sam Foster

Cc: wildbill Becky Gibson added
Keywords: a11y added

Definately a FF3 bug. See the reduced test case which presents an unstyled button (works fine in high contrast mode) and a 1px border test case - which shows the same issue described for this ticket. We /could/ fix it by setting border width/style to auto for high contrast? That might not be a bad idea all around.. what do you think?

Changed 11 years ago by Sam Foster

comment:8 Changed 11 years ago by bill

Milestone: 1.11.2
Summary: FF3: Most button top/bottom borders are missing in High Contrast modeButton: Most button top/bottom borders are missing in High Contrast mode (FF3)

Seems fine to me; becky if this looks ok please check in.

comment:9 Changed 11 years ago by Becky Gibson

Sorry, I missed the window for 1.1 but will check in as soon as there is a 1.1.x branch. Since this is FF3 (and it seems to be behind schedule) I'm not worried about this missing 1.1).

comment:10 Changed 11 years ago by Becky Gibson

Description: modified (diff)
Milestone: 1.21.1.1

comment:11 Changed 11 years ago by Becky Gibson

Resolution: fixed
Status: reopenedclosed

fixed in [13264] for 1.2 and [13265] for 1.1.1

comment:12 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.