Opened 12 years ago

Closed 11 years ago

#4178 closed defect (wontfix)

Superfluous dijitSplitContainerSizerV being created on programmatic SplitContainer

Reported by: gizmojo.org Owned by: Adam Peller
Priority: high Milestone: 1.1
Component: Dijit Version: 0.9
Keywords: Sizer bordercontainer Cc:
Blocked By: Blocking:

Description

Creating a SplitContainer? entirely progammatically, including the target div element, gives what seems like a superfluous dijitSplitContainerSizerV element, that is rendered (FF2.0, W2k, Dojo rev 10182) in the top left corner of the SplitContainer? area, as a short horizontal piece of line -- that is however grab-able with the mouse, and grabbing it spews out a stream of errors: this.paneBefore has no properties.

A test file (plus some more description) to reproduce the problem is at: http://dojotoolkit.org/forum/dijit-dijit-0-9/dijit-support/superfluous-dijitsplitcontainersizerv-being-cerated-programmatic

The test file creates a SplitContainer? and two child ContentPanes?. Poking the DOM for the #mysc SplitContainer? element with FireBug?, there are 2 dijitSplitContainerSizerV elements. The first one is the expected one between the two ContentPanes?, and the other is the superfluous one described above. Deleting this second one from the DOM seems to make the page work correctly.

Change History (6)

comment:1 Changed 12 years ago by bill

Milestone: 1.0
Owner: set to Adam Peller

comment:2 Changed 12 years ago by gizmojo.org

Cc: mario@… removed

comment:3 Changed 12 years ago by gizmojo.org

Reporter: changed from guest to gizmojo.org

comment:4 Changed 12 years ago by Adam Peller

Milestone: 1.01.1

comment:5 Changed 11 years ago by Adam Peller

Keywords: bordercontainer added

comment:6 Changed 11 years ago by Adam Peller

Resolution: wontfix
Status: newclosed

deprecated SplitContainer? in favor of BorderContainer?

Note: See TracTickets for help on using tickets.