Opened 12 years ago

Closed 11 years ago

#4139 closed defect (fixed)

Dialog: horizontal scrollbar on browser window (Safari/Webkit)

Reported by: haysmark Owned by: bill
Priority: high Milestone: 1.3
Component: Dijit Version: 0.9
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

See http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/test_Dialog.html

If you click the Show Dialog button in test_Dialog, you get horizontal scrollbar on the browser window.

Attachments (1)

dialogscrollbars.JPG (69.3 KB) - added by haysmark 12 years ago.
Picture of Dialog horizontal scrollbar bug from Webkit 3.0.4 (does not affect Safari 3.0.2)

Download all attachments as: .zip

Change History (10)

comment:1 Changed 12 years ago by haysmark

Description: modified (diff)

comment:2 Changed 12 years ago by haysmark

Description: modified (diff)

comment:3 Changed 12 years ago by bill

Milestone: 1.01.1

Doug and I can't reproduce this one? PC or Mac? Webkit nightly of Safari 3.0.3? (We tried all of those but still couldn't get it to happen.) First button in test_Dialog?

comment:4 Changed 12 years ago by haysmark

I originally saw this in Webkit r24872 (that's 3.0). I am actually not seeing it in my Safari (3.0.2), just Webkit. I just upgraded to r25545 (that's 3.0.4) and I still see it.

Click the first button in the upper left, called Show Dialog, which creates a dialog with a dialog title "First Dialog." I will attach a screenshot.

Changed 12 years ago by haysmark

Attachment: dialogscrollbars.JPG added

Picture of Dialog horizontal scrollbar bug from Webkit 3.0.4 (does not affect Safari 3.0.2)

comment:5 Changed 12 years ago by bill

Description: modified (diff)
Milestone: 1.12.0
Summary: Safari/Webkit: Dialog: horizontal scrollbars on modal dialogDialog: horizontal scrollbar on browser window (Safari/Webkit)

comment:6 Changed 12 years ago by alex

Milestone: 2.01.3

Milestone 2.0 deleted

comment:7 Changed 11 years ago by JP

This is still a problem. If you have a dialog in Safari, when the dialog is shown, a horizontal scroll bar appears at the botton of the browser window. You can then scroll horizontally forever. This is a real problem for production applications using Dojo. Is there a quick fix for this?

comment:8 Changed 11 years ago by bill

Description: modified (diff)
Owner: set to bill
Status: newassigned

Yup, I see the problem on Safari 3.1 mac too.

Note that we have to branch based on whether the document is strict or compat mode (IE, whether or not there's a DOCTYPE header). Yes, on Safari...

comment:9 Changed 11 years ago by bill

Resolution: fixed
Status: assignedclosed

Fixed by [15643]

Note: See TracTickets for help on using tickets.