Opened 12 years ago

Closed 12 years ago

#4100 closed defect (invalid)

Dynamically added AccordionPane's are rendering after being created

Reported by: guest Owned by: Adam Peller
Priority: high Milestone: 1.0
Component: Dijit Version: 0.9
Keywords: AccordionContainer, AccordionPane, Dynamically Cc:
Blocked By: Blocking:

Description

When dynamically creating AccordionPane?'s, my browser (firefox 2.0.0.x) only renders one of the panes (the first added).

After a physical resize of the browser window, the other pane's appear and all behave as expected.

I'm using yesterdays nightly (August the 11th).

Attachments (1)

accordion_testcase.html (882 bytes) - added by guest 12 years ago.
Testcase with dynamically added accodionpanes

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by guest

Attachment: accordion_testcase.html added

Testcase with dynamically added accodionpanes

comment:1 Changed 12 years ago by guest

And, because it was requested in IRC, tried against SVN head and the problem still exists.

comment:2 Changed 12 years ago by bill

Milestone: 1.0
Owner: set to Adam Peller

comment:3 Changed 12 years ago by Adam Peller

Resolution: invalid
Status: newclosed

sorry for taking so long to get back to you on this. the problem is that you have to call startup() so the widget knows when to lay itself out. seems awkward, I know. We tried to document this in the book. If you think there's somewhere else we can make this more clear, please let us know.

Note: See TracTickets for help on using tickets.