Opened 12 years ago

Closed 10 years ago

Last modified 8 years ago

#4099 closed task (fixed)

Tundra: focus indication for checkboxes and radios (and other widgets?)

Reported by: bill Owned by: Sam Foster
Priority: high Milestone: 1.2
Component: Dijit - Form Version: 0.9
Keywords: Cc: Becky Gibson
Blocked By: Blocking:

Description

[10006] sort of made focus visible on checkboxes and radio buttons, but I don't think anyone besides us will notice; need better CSS rules.

Attachments (1)

checkbox.png (5.8 KB) - added by bill 10 years ago.
example of checkbox focus indication (by focus border on label)

Download all attachments as: .zip

Change History (11)

comment:1 Changed 12 years ago by Adam Peller

Owner: set to dante

comment:2 Changed 12 years ago by Adam Peller

Owner: changed from dante to Sam Foster

comment:3 Changed 12 years ago by bill

Milestone: 1.02.0

Maybe we should make focus look the same as hover. Or change the border to a different color?

Note that this isn't an A11Y requirement per se since the checkboxes in general don't show focus.

comment:4 Changed 12 years ago by ptbrunet

This is the text from #5098 which was closed as a duplicate of this:

There is no focus box on dojo checkboxes or radio buttons. The styling on radio buttons seems fairly clear as an indicator. However, since it's a different means of conveying the focus indicator it would be confusing to users. For unchecked checkboxes I don't see any change and for checked checkboxes I don't think changing the style to have the shading gradient flip directions is helpful enough.

This is also a Firefox issue. In IE the text for the checkbox gets the focus box. This is done by IE and not within Dojo because the Dojo checkbox just overlay's a standard HTML checkbox. Firefox does not put the focus box on the label, making it hard to distinguish even the normal checkbox found on the checkbox test page (cb7). Dojo could do a better job of showing focus on checkboxes but Firefox could as well.

comment:5 Changed 11 years ago by alex

Milestone: 2.01.3

Milestone 2.0 deleted

comment:6 Changed 11 years ago by bill

Milestone: 1.31.2
Resolution: fixed
Status: newclosed

This was fixed by [13332].

comment:7 in reply to:  6 Changed 10 years ago by Prutkar

Resolution: fixed
Status: closedreopened

Replying to bill:

This was fixed by [13332].

I can see some sort of checkbox change when I hover mouse over checkbox, but I surely see absolutely no indication that checkbox has focus when I use TAB to get to it.

comment:8 Changed 10 years ago by Adam Peller

Cc: Becky Gibson added

comment:9 Changed 10 years ago by bill

Resolution: fixed
Status: reopenedclosed

As the checkin comment says, it's indicated by a focus border around the label:

example of checkbox focus indication (by focus border on label)

Are you not seeing that on your system? Maybe you don't have a label on your checkbox.

Changed 10 years ago by bill

Attachment: checkbox.png added

example of checkbox focus indication (by focus border on label)

comment:10 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.