Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#4087 closed defect (invalid)

FilteringSelect allows values not in set of valid values

Reported by: ptbrunet Owned by: haysmark
Priority: high Milestone: 1.0
Component: Dijit - Form Version: 0.9
Keywords: Cc: ptbrunet
Blocked By: Blocking:

Description

The prolog to FilteringSelect says: "You can only enter a value from the drop down list. (You can't enter an arbitrary value.)".

Go to the inline test case, tab down to the FilteringSelect, backspace over all the text and type in an x then tab away. The x value is accepted and displayed.

BTW, The underlying value of IA (Iowa) is maintained so it would be confusing to have a displayed value of x representing IA.

Change History (3)

comment:1 Changed 12 years ago by ptbrunet

Owner: set to haysmark

comment:2 Changed 12 years ago by bill

Resolution: invalid
Status: newclosed

Right, by design we let the user input any value, even invalid values, but they have to correct it to a value from the drop down list before submitting the form... eventually we will prevent the form from being submitted if any of the fields are invalid.

I'm not sure if there's a better wording for the prolog.

The thing about the hidden value remaining is listed in #4010.

comment:3 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.