Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#4086 closed defect (fixed)

FilteringSelect: Invalid message alert not popping up

Reported by: ptbrunet Owned by: haysmark
Priority: high Milestone: 1.0
Component: Dijit - Form Version: 0.9
Keywords: Cc: ptbrunet
Blocked By: Blocking:

Description

Using the inline test case, enter invalid text into the state entry box, e.g. Iowax. An alert popup should appear such as those that appear in the validate test case.

Attachments (1)

4086.patch (1.4 KB) - added by haysmark 12 years ago.
Fix for 1.0 trunk

Download all attachments as: .zip

Change History (12)

comment:1 Changed 12 years ago by ptbrunet

Owner: set to haysmark

The test case is .../dijit/tests/form/test_InlineEditBox.html

comment:2 Changed 12 years ago by bill

Summary: Invalid message alert not popping up on FilteringSelectFilteringSelect: Invalid message alert not popping up

comment:3 Changed 12 years ago by haysmark

The inheritance is not calling ValidationTextBox? code like I thought. I will have to address the postMixInProperties and postCreate prototypes directly.

Changed 12 years ago by haysmark

Attachment: 4086.patch added

Fix for 1.0 trunk

comment:4 Changed 12 years ago by haysmark

Status: newassigned

comment:5 Changed 12 years ago by haysmark

So FilteringSelect? already works standalone. The patch I appended makes it work in InlineEditBox?, but breaks the standalone case.

comment:6 Changed 12 years ago by haysmark

Actually I can't reproduce the problem I was having earlier, so this patch should work.

comment:7 Changed 12 years ago by haysmark

Nevermind again, here is the error:

[Exception... "'dijit.form.FilteringSelect?: name argument ("postMixInProperties") to inherited must match callee (declare.js)' when calling method: [nsIDOMEventListener::handleEvent]" nsresult: "0x8057001e (NS_ERROR_XPC_JS_THREW_STRING)" location: "<unknown>" data: no]

Line 0

comment:8 Changed 12 years ago by haysmark

Right, so here is what is going on:

The i18n is not being loaded, period. That means the default message does not appear. You see the tooltips in test_FilteringSelect because those are all user-defined.

I don't know why I am getting that error yet but I am working on it.

comment:9 Changed 12 years ago by haysmark

The problem is in test_FilteringSelect. Someone added script tags to manually load FilteringSelect?.js and ValidationTextBox?.js. Removing these extra tags fixed the test.

comment:10 Changed 12 years ago by Douglas Hays

Resolution: fixed
Status: assignedclosed

(In [10376]) Fixes #4086. Proxy commit for haysmark. Added calls to postMixinProperties and postCreate of ValidationTextBox? and MappedTextBox? in ComboBox? and FilteringSelect?, in order to get the default error message to load. Removed extraneous script tags from the test_FilteringSelect tests, which were conflicting with this fix.

comment:11 Changed 9 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.