Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#4072 closed defect (fixed)

Spinner / Combo / SelectBox can break in IE with some select/mouseup operations

Reported by: Sam Foster Owned by: bill
Priority: high Milestone: 0.9
Component: Dijit - Form Version: 0.9
Keywords: ie Cc: bill, davidb, Douglas Hays
Blocked By: Blocking:

Description

If you select the value in any of the text input field-based form widgets, and cause the mouseup to fire outside the widget (e.g. select right to left) you get an "Object doesnt support this property or method"

The while loop in _FormWidget's _onMouse method can get the document node (in ie6, 7), which fails (as it doesnt have a getAttribute method). I'm attaching a patch to also check for node.nodeType === 1 (and that's all the patch does).

Attachments (1)

formwidget_mouseup_sfoster_20070809.patch (597 bytes) - added by Sam Foster 12 years ago.
(CLA) (Patch) one line change to dijit/form/_FormWidget.js to head off [document].getAttribute()

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by Sam Foster

(CLA) (Patch) one line change to dijit/form/_FormWidget.js to head off [document].getAttribute()

comment:1 Changed 12 years ago by Sam Foster

Owner: changed from Sam Foster to bill

Assigning to bill for his review.

comment:2 Changed 12 years ago by bill

Hmm, I'm having trouble reproducing this and also I don't understand the relevance of mouseup, since you are changing the code for the mouseover handler.

comment:3 Changed 12 years ago by bill

Resolution: fixed
Status: newclosed

(In [10101]) Fixes #4072: Spinner / Combo / SelectBox? can break in IE with some select/mouseup operations. Patch from Sam Foster (CLA on file)

comment:4 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.