Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#4051 closed defect (fixed)

Pressing enter on inline autoSave FilteringSelect doesn't close the box.

Reported by: ptbrunet Owned by: haysmark
Priority: high Milestone: 1.0
Component: Dijit - Form Version: 0.9
Keywords: Cc: brunet@…
Blocked By: Blocking:

Description

Pressing Enter on autoSave inlines should close the widget. However this doesn't happen for FilteringSelect. This is due to ComboBox::onkeypress eating the Enter key.

Change History (7)

comment:1 Changed 12 years ago by bill

Milestone: 0.91.0
Owner: changed from bill to haysmark

comment:2 Changed 12 years ago by haysmark

Yes, this is related to #3785.

comment:3 Changed 12 years ago by Douglas Hays

(In [10023]) Fixes #3785. References #4051. Proxy commit for haysmark. ComboBox? stopped stealing focus after the user selects an option from the list. ComboBox? allows the Enter key to bubble so InlineEditBox? hears it (still bugged in IE).

comment:4 Changed 12 years ago by haysmark

So now the problem is event.js in dojo core is setting the keyCode to 0 in IE. This means that InlineEditBox? hears 0 instead of Enter when the user presses Enter in ComboBox?.

comment:5 Changed 12 years ago by haysmark

See #4064.

comment:6 Changed 12 years ago by haysmark

Resolution: fixed
Status: newclosed

comment:7 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.